<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9k973w2" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9k973w2";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Suspects Released In Austin Shots Fired Incident - KTTC Rochester, Austin, Mason City News, Weather and Sports</title>
<meta name="Description" content="Five suspects have been released after a shots fired incident on Sunday, but they could face charges by summons.   "><meta name="KEYWORDS" content="kttc,rochester,minnesota,mn,news,news center,10,breaking news,local news,mayo clinic,ibm,austin,albert lea,winona,mason city&#xD;&#xA;"><meta name="news_keywords" content="kttc,rochester,minnesota,mn,news,news center,10,breaking news,local news,mayo clinic,ibm,austin,albert lea,winona,mason city&#xD;&#xA;"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2018/03/27"><meta name="owner" content="KTTC"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="7.3.20.1"><meta name="wn-base" content="IIS16"><meta name="wnreadableurl" content="suspects-released-in-austin-shots-fired-incident"><meta name="wnreadabledate" content="2018/03/27"><meta property="og:title" content="Suspects Released In Austin Shots Fired Incident"><meta property="og:type" content="article"><meta property="og:url" content="http://www.kttc.com/story/37821597/2018/03/Tuesday/suspects-released-in-austin-shots-fired-incident"><meta property="og:image" content="http://KTTC.images.worldnow.com/images/16407914_G.jpg"><meta property="og:description" content="Five suspects have been released after a shots fired incident on Sunday, but they could face charges by summons.   "><link rel="canonical" href="http://www.kttc.com/story/37821597/2018/03/Tuesday/suspects-released-in-austin-shots-fired-incident"><meta name="author" content="James Bunner"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Suspects Released In Austin Shots Fired Incident"><meta name="twitter:description" content="Five suspects have been released after a shots fired incident on Sunday, but they could face charges by summons.   "><meta name="twitter:image" content="http://KTTC.images.worldnow.com/images/16407914_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta name='verify-v1' content='RdB/QY3JvkKlmIVJQYs5oBhteC0S/IPXcq/9A/VaHes=' /><meta name="google-site-verification" content="bMnk8RWoHmafMEoMBDFXckKRNku8S1RzP7St5gp_7Lo" /><!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=7.3.20.1_7.4.8-8">
<link type="text/css" rel="stylesheet" media="all" href="http://KTTC.images.worldnow.com/interface/css/container-e.css?ver=2018-02-22%2015%3A29%3A17_7.4.8-8">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.4.8-8_7.3.20.1" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=7.3.20.1"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=7.3.20.1"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=7.3.20.1"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1348 UL
                    , #menu1348 .wnHorizontal { background-color: #eaeaea; font-family: Arial; font-size: 11px; font-weight: 700; color: #ffffff; }
                #menu1348 A,
                    #menu1348 LI.wnOn .wnSublevel A,
                    #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 11px; font-weight: 700; color: #ffffff; }
                #menu1348 .wnHorizontal .wnDynamic .wnMenuTypeText
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { padding-right: 15px; }
                #menu1348
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_tridown.gif') no-repeat 98% 50%; }
                #menu1348
                        .wnLevel1 LI.wnHasSublevel .wnLevel2 .wnMiddle SPAN { background: none; }
            #menu1348 UL LI.wnOn { background-color: #eaeaea; color: #000000; }
                    #menu1348 LI.wnOn A,
                        #menu1348 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1348 .wnSublevel { background-color: #eaeaea; color: #000000; }
                #menu1348 LI.wnOn .wnSublevel A,
                    #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { color: #000000; }
                #menu1348 .wnSublevel A { border : 1px #eaeaea solid; border-top: none; }
                        #menu1348 .wnSublevel .wnFirstNode { border-top : 1px #eaeaea solid; }
                        #menu1348 .wnHorizontal .wnDynamic .wnMenuTypeText .wnSublevel LI.wnHasSublevel A { padding-right: 9px; }
                #menu1348 .wnSublevel LI.wnHasSublevel A { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_tri.gif') no-repeat 98% 50%; }
                #menu1348 .wnSublevel LI.wnHasSublevel .wnLevel3 A { background: none; }
            #menu1348 .wnSublevel LI.wnOn {  color: #142c8e; }
                    #menu1348 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #142c8e; }
                    #menu1348 .wnLeft { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 6px; }
                    #menu1348 LI.wnOn .wnLeft { background-image: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1348 .wnRight { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 6px; }
                    #menu1348 LI.wnOn .wnRight { background-image: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1348 .wnRight .wnMiddle { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1348 LI.wnOn .wnMiddle { background-image: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'KTTC',
            affiliateId : '720',
            baseUrl : 'www.kttc.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.4.8-8',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '44',mdPartnerDomain : 'http://dub.kttc.com'},
            registrationId : '557026',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://KTTC.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='7.3.20.1';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.disableSecurityWarning=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='KTTC';
wng_pageInfo.ownerAffiliateId=parseInt('720',10);
wng_pageInfo.containerId=parseInt('37821597',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='News';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident';
wng_pageInfo.content_authors='James Bunner';
wng_pageInfo.headline='Suspects Released In Austin Shots Fired Incident';
wng_pageInfo.pageTitle='Suspects Released In Austin Shots Fired Incident - KTTC Rochester, Austin, Mason City News, Weather and Sports';
wng_pageInfo.pageTitleTag='KTTC Rochester, Austin, Mason City News, Weather and Sports';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffKTTC';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KTTC'},width:468,height:60,wncc:"News",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KTTC'},width:468,height:60,wncc:"News",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:728,height:90,wncc:"News",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:300,height:250,wncc:"News",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["44"]={id:"44",wnsz:"44",ownerinfo:{oldformat:1,owner:'nat',split:'100',type:'inline',aff:'KTTC'},width:300,height:75,wncc:"News",parent:"WNAd44",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:728,height:90,wncc:"News",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_47 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:300,height:250,wncc:"News",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_63 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.adsettings={disableInitialLoad:true};</script>
<script type="text/javascript" src="http://KTTC.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2018-02-22%2015%3A29%3A17_7.4.8-8"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/KTTC.config.js?ver=7.3.20.1_7.4.8-8"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=7.3.20.1_7.4.8-8"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><script language='JavaScript1.1' src='//pixel.mathtag.com/event/js?mt_id=1013608&mt_adid=163437&v1=&v2=&v3=&s1=&s2=&s3='></script><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Roboto:400,700|Roboto+Condensed:400,700"><link type="text/css" rel="stylesheet" href="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/custom-master.css"><link type="text/css" rel="stylesheet" href="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/kttc/custom.css"><script src="//acdn.adnxs.com/prebid/c/7045/pb.js"></script><script src="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/custom-master.js"></script><script src="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/kttc/custom.js"></script></head><body id="WNAffKTTC" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-91' ,"dma":'153' ,"group":'Quincy'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Suspects Released In Austin Shots Fired Incident - KTTC Rochester, Austin, Mason City News, Weather and Sports</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/search"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://KTTC.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://KTTC.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1348" class="wnMainMenu"><div class="wnHorizontal"><div class="wnDynamic"><div class="wnMenuTypeText"><ul class="wnLevel1" id="submenu1348"><li class="wnFirstNode" id="menu1348_1-C123673"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/">HOME</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_1-C123673"><li class="wnFirstNode" id="menu1348_1_1-S30242200"><span><a href="/story/30242200/2015/10/12/contact-kttc">Contact KTTC</a></span></li><li class="" id="menu1348_1_2-C131449"><span><a href="/category/131449/about-us">ABOUT US</a></span></li><li class="" id="menu1348_1_3-C134180"><span><a href="/category/134180/kttc-jobs">KTTC Jobs</a></span></li><li class="" id="menu1348_1_4-L694740"><span><a href="javascript:OpenWin('http://share.kttc.com||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Share photos and videos with us</a></span></li><li class="" id="menu1348_1_5-C134984"><span><a href="/category/134984/kttc-viewer-survey">KTTC Viewer Survey</a></span></li><li class="" id="menu1348_1_6-L795709"><span><a href="https://quincify.com/">Quincify Digital Advertising</a></span></li><li class="" id="menu1348_1_7-L481961"><span><a href="https://xprspay.ipayxepay.net/xprspay/qmi/index.jsp">Advertiser Services</a></span></li></ul></li><li class="" id="menu1348_2-C123676"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/123676/news">NEWS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_2-C123676"><li class="wnFirstNode" id="menu1348_2_1-C50681"><span><a href="/category/50681/minnesota-headlines">Minnesota Headlines</a></span></li><li class="" id="menu1348_2_2-C50694"><span><a href="/category/50694/iowa-headlines">Iowa Headlines</a></span></li><li class="" id="menu1348_2_3-C132472"><span><a href="/category/132472/health-beat">Health Beat</a></span></li><li class="" id="menu1348_2_4-C318331"><span><a href="/category/318331/throwback-thursday">Throwback Thursday </a></span></li><li class="" id="menu1348_2_5-C151577"><span><a href="/category/151577/your-money">Your Money</a></span></li><li class="" id="menu1348_2_6-L713987"><span><a href="http://www.kttc.com/category/68446/lifestyle">Lifestyle</a></span></li><li class="" id="menu1348_2_7-C132494"><span><a href="/category/132494/newscenter-extras">NewsCenter Extras</a></span></li><li class="" id="menu1348_2_8-C131448"><span><a href="/category/131448/links">Links</a></span></li><li class="" id="menu1348_2_9-L569193"><span><a href="http://kttc.tributes.com">Obituaries</a></span></li><li class="" id="menu1348_2_10-S25569165"><span><a href="/story/25569165/2014/05/20/download-the-kttc-news-app">Download the KTTC news app</a></span></li></ul></li><li class="" id="menu1348_3-C123674"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather">WEATHER</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_3-C123674"><li class="wnFirstNode" id="menu1348_3_1-C162320"><span><a href="/category/162320/kttc-interactive-radar">KTTC Interactive Radar</a></span></li><li class="" id="menu1348_3_2-C153919"><span><a href="/category/153919/stormcenter-closings-and-delays">StormCenter Closings and Delays</a></span></li><li class="" id="menu1348_3_3-L313522"><span><a href="javascript:OpenWin('/link/313522/traffic-road-conditions||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Traffic &amp; Road Conditions</a></span></li><li class="" id="menu1348_3_4-C132833"><span><a href="/category/132833/skycams">Skycams</a></span></li><li class="" id="menu1348_3_5-L476803"><span><a href="javascript:OpenWin('http://addins.kttc.com/blogs/weather/||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">KTTC Weather Blog</a></span></li><li class="" id="menu1348_3_6-S19685197"><span><a href="/story/19685197/weather-app-information">Get the KTTC Precision Weather app</a></span></li><li class="" id="menu1348_3_7-S30259342"><span><a href="/story/30259342/2015/10/14/sign-up-for-kttcs-new-weather-email-plus-breaking-news-email">Sign up for KTTC's new weather email </a></span></li></ul></li><li class="" id="menu1348_4-C123677"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/123677/sports">SPORTS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_4-C123677"><li class="wnFirstNode" id="menu1348_4_1-C134846"><span><a href="/category/134846/athlete-of-the-week">Athlete of the Week</a></span></li><li class="" id="menu1348_4_2-C178278"><span><a href="/category/178278/weekly-sports-scores">Weekly Sports Scores</a></span></li></ul></li><li class="" id="menu1348_5-C280285"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/280285/slideshows-and-lists">SLIDESHOWS</a></span></span></span></span></li><li class="" id="menu1348_6-C131445"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/131445/video">VIDEO</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_6-C131445"><li class="wnFirstNode" id="menu1348_6_1-L314812"><span><a href="javascript:OpenWin('http://KTTC.images.worldnow.com/library/0bf61a61-116c-4987-b433-435c57376f4c.pdf||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Request Video</a></span></li></ul></li><li class="" id="menu1348_7-C123678"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/123678/community">THINGS TO DO</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_7-C123678"><li class="wnFirstNode" id="menu1348_7_1-L785736"><span><a href="javascript:OpenWin('http://www.rochestermn.gov/departments/fire/clock-and-bell-tower||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Bring Back Clock Tower &amp; Bell</a></span></li><li class="" id="menu1348_7_2-L755054"><span><a href="javascript:OpenWin('http://www.kttc.com/category/123678/community#/55904-rochester/all/today||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Community Calendar</a></span></li><li class="" id="menu1348_7_3-C131447"><span><a href="/category/131447/contests">Contests</a></span></li><li class="" id="menu1348_7_4-C167146"><span><a href="/category/167146/kttc-pet-of-the-week">KTTC Pet of the Week</a></span></li><li class="" id="menu1348_7_5-C167922"><span><a href="/category/167922/kttc-on-the-road">KTTC 'On the Road'</a></span></li><li class="" id="menu1348_7_6-L747132"><span><a href="http://kttc.upickem.net/engine/Welcome.aspx?contestid=177023">KTTC Young Leaders</a></span></li><li class="" id="menu1348_7_7-L313404"><span><a href="javascript:OpenWin('/link/313404/mr-food||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Mr. Food</a></span></li><li class="" id="menu1348_7_8-S16686978"><span><a href="/story/16686978/kttc-business-spotlight">Business Spotlight</a></span></li><li class="" id="menu1348_7_9-C170573"><span><a href="/category/170573/birthday-spotlight">Birthday Spotlight</a></span></li><li class="" id="menu1348_7_10-C135324"><span><a href="/category/135324/gas-buddy">Gas Buddy</a></span></li></ul></li><li class="" id="menu1348_8-C131446"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/131446/whats-on">WHAT'S ON</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_8-C131446"><li class="wnFirstNode" id="menu1348_8_1-C297536"><span><a href="/category/297536/heroes-icons">Heroes &amp; Icons</a></span></li><li class="" id="menu1348_8_2-L758546"><span><a href="javascript:OpenWin('http://www.kttc.com/category/131446/whats-on||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Program Guide</a></span></li><li class="" id="menu1348_8_3-C195218"><span><a href="/category/195218/nbc-programming">NBC Programming</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1348"></div></div></div></div><div id="spacermenu1348" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1348', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : false, level1ArrowPadding : '15', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://KTTC.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://KTTC.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Suspects Released In Austin Shots Fired Incident</h3>
<em class="wnDate">Posted: 
<script type="text/javascript">
                                wnRenderDate('Tuesday, March 27, 2018 4:17 PM EDT', '', false);</script>
</em><noscript><em class="wnDate">Tuesday, March 27, 2018 4:17 PM EDT</em></noscript><!--END wnDate-->
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div id="WNStoryByline" class="bylines wn-row"><div class="byline wn-row"><span class="author">By James Bunner, Reporter</span><div class="simple"><span class="email item"><a target="_self" title="" href="mailto:jbunner@kttc.com?body=http://www.kttc.com/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident">Email</a></span></div><div class="wn-anchor"><a href="#" class="connect">Connect</a><div class="connect off"><div class="email item"><a target="_self" title="" href="mailto:jbunner@kttc.com?body=http://www.kttc.com/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident">jbunner@kttc.com</a></div></div></div></div></div><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnRight" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://KTTC.images.worldnow.com/images/16407914_G.jpg" alt="" title="" border="0" width="180">
</div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://KTTC.images.worldnow.com/images/16407917_G.jpg" alt="McCayla Hernandez" title="McCayla Hernandez" border="0" width="180">
<span>McCayla Hernandez</span></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://KTTC.images.worldnow.com/images/16407923_G.jpg" alt="Erick Lozano-Godina" title="Erick Lozano-Godina" border="0" width="180">
<span>Erick Lozano-Godina</span></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://KTTC.images.worldnow.com/images/16407924_G.jpg" alt="Austin Navarro" title="Austin Navarro" border="0" width="180">
<span>Austin Navarro</span></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://KTTC.images.worldnow.com/images/16407926_G.jpg" alt="Felipe Carrizales" title="Felipe Carrizales" border="0" width="180">
<span>Felipe Carrizales</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated right"><span id="WNStoryDateline">AUSTIN, Minn. (KTTC) -
            </span><p>Five suspects have been released after a shots fired incident on Sunday, but they could face charges by summons.&nbsp; That's the word from Court Administration.&nbsp; Law enforcement is still looking for a group of people described as African-American males who were reportedly involved in the incident.&nbsp;&nbsp;</p><p>On Sunday around 1:00 in the morning, an incident happened at El Maguey Bar in Austin.&nbsp; Reports came in that it started as a bar fight stemming from an altercation on the dance floor and spilled outside.&nbsp; Witnesses say at least three shots were fired.&nbsp; A threat had allegedly been made to shoot someone, but no injuries or damage to property was reported.&nbsp;&nbsp;</p><p>Information from law enforcement authorities indicates that when officers arrived on the scene, they were directed to an SUV with Wisconsin plates parked at the Spam Museum.&nbsp; A small amount of marijuana was found in the SUV as well as a 38 special revolver.&nbsp; Four rounds had been spent from the revolver and it had one round still in the chamber.&nbsp;</p><p>Five people were arrested.&nbsp; They have been identified as 18-year-old Carlie Ubaldo of Austin, 18-year-old McCayla Hernandez of Albert Lea, 19-year-old Erick Lozano-Godina of Albert Lea, 23-year-old Felipe Carrizales of Albert Lea, and 19-year-old Austin Navarro of Albert Lea.&nbsp; All potentially face charges of open bottle, misdemeanor drug possession, gross misdemeanor or possession of a firearm with ammunition, gross misdemeanor of carry and possession without a permit in public.&nbsp; Hernandez and Navarro potentially face charges of drinking under the age of 21.&nbsp;&nbsp;</p><p>The case remains under investigation.&nbsp;&nbsp;</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd44" class="wnad wnad44">
<script>wnad_44.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Headline Box - Col 4 (78)--><div class="wnBlock displaySize displaySizeId78 headlineBox" id="DisplaySizeId78"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Mobile Top Stories</span><a class="wnContent more enabled" href="/category/250927/mobile-top-stories"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature News story priority-1 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2018-03-27 20:28:30"><h4 class="wnContent headline"><a href="/story/37821811/2018/03/27/blooming-prairie-residents-hope-for-more-clarity-regarding-homicide-investigation"><span class="text">Blooming Prairie residents hope for more clarity regarding homicide investigation</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37821811/2018/03/27/blooming-prairie-residents-hope-for-more-clarity-regarding-homicide-investigation"><span class="text">Blooming Prairie residents hope for more clarity regarding homicide investigation</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37821811/2018/03/27/blooming-prairie-residents-hope-for-more-clarity-regarding-homicide-investigation"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16408031_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37821811/2018/03/27/blooming-prairie-residents-hope-for-more-clarity-regarding-homicide-investigation"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16408031_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>A homicide in the small town of Blooming Prairie on Friday leaves its residents wondering exactly happened and why. David Riess, 54, was found dead in his home as a result of multiple gunshot wounds. Blooming Prairie Police said&nbsp;he was found after doing a welfare check on him. They said&nbsp;he was supposed to go on a fishing trip&nbsp;when someone who knew him couldn't get a hold of him,and called police to check on him. W</p></span><a class="more" href="/story/37821811/2018/03/27/blooming-prairie-residents-hope-for-more-clarity-regarding-homicide-investigation"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A homicide in the small town of Blooming Prairie on Friday leaves its residents wondering exactly happened and why. David Riess, 54, was found dead in his home as a result of multiple gunshot wounds. Blooming Prairie Police said&nbsp;he was found after doing a welfare check on him. They said&nbsp;he was supposed to go on a fishing trip&nbsp;when someone who knew him couldn't get a hold of him,and called police to check on him. W</p></span><a class="more" href="/story/37821811/2018/03/27/blooming-prairie-residents-hope-for-more-clarity-regarding-homicide-investigation"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-7 even-7"><meta content="News"><meta content="2018-03-27 20:17:16"><h4 class="wnContent headline"><a href="/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident"><span class="text">Suspects Released In Austin Shots Fired Incident</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident"><span class="text">Suspects Released In Austin Shots Fired Incident</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16407914_G.jpg" title="Carlie Ubaldo" alt="Carlie Ubaldo"></a><span class="caption left width90"><span class="text">Carlie Ubaldo</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16407914_G.jpg" title="Carlie Ubaldo" alt="Carlie Ubaldo"></a><span class="caption left width90"><span class="text">Carlie Ubaldo</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Five suspects have been released after a shots fired incident on Sunday, but they could face charges by summons.&nbsp;&nbsp;</p></span><a class="more" href="/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Five suspects have been released after a shots fired incident on Sunday, but they could face charges by summons.&nbsp;&nbsp;</p></span><a class="more" href="/story/37821597/2018/03/27/suspects-released-in-austin-shots-fired-incident"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2018-03-27 17:26:41"><h4 class="wnContent headline"><a href="/story/37820288/2018/03/27/minnesota-farmers-endured-5th-straight-year-of-thin-profits"><span class="text">Minnesota farmers endured 5th straight year of thin profits</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37820288/2018/03/27/minnesota-farmers-endured-5th-straight-year-of-thin-profits"><span class="text">Minnesota farmers endured 5th straight year of thin profits</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37820288/2018/03/27/minnesota-farmers-endured-5th-straight-year-of-thin-profits"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16406838_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37820288/2018/03/27/minnesota-farmers-endured-5th-straight-year-of-thin-profits"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16406838_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A new report says bumper crops and occasional upticks in prices weren't enough to save most Minnesota farmers from a fifth straight year of thin profits in 2017.</p></span><a class="more" href="/story/37820288/2018/03/27/minnesota-farmers-endured-5th-straight-year-of-thin-profits"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A new report says bumper crops and occasional upticks in prices weren't enough to save most Minnesota farmers from a fifth straight year of thin profits in 2017.</p></span><a class="more" href="/story/37820288/2018/03/27/minnesota-farmers-endured-5th-straight-year-of-thin-profits"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2018-03-27 17:11:01"><h4 class="wnContent headline"><a href="/story/37820153/2018/03/27/iowa-selects-5-cities-for-medical-marijuana-dispensaries"><span class="text">Iowa selects 5 cities for medical marijuana dispensaries</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37820153/2018/03/27/iowa-selects-5-cities-for-medical-marijuana-dispensaries"><span class="text">Iowa selects 5 cities for medical marijuana dispensaries</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37820153/2018/03/27/iowa-selects-5-cities-for-medical-marijuana-dispensaries"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16406674_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37820153/2018/03/27/iowa-selects-5-cities-for-medical-marijuana-dispensaries"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16406674_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A state agency has offered licenses to three companies to operate medical marijuana dispensaries in Iowa.</p></span><a class="more" href="/story/37820153/2018/03/27/iowa-selects-5-cities-for-medical-marijuana-dispensaries"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A state agency has offered licenses to three companies to operate medical marijuana dispensaries in Iowa.</p></span><a class="more" href="/story/37820153/2018/03/27/iowa-selects-5-cities-for-medical-marijuana-dispensaries"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-5 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content="2018-03-27 16:59:59"><h4 class="wnContent headline"><a href="/story/37820079/2018/03/27/minnesota-team-raises-money-to-buy-championship-rings"><span class="text">Minnesota team raises money to buy championship rings</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37820079/2018/03/27/minnesota-team-raises-money-to-buy-championship-rings"><span class="text">Minnesota team raises money to buy championship rings</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37820079/2018/03/27/minnesota-team-raises-money-to-buy-championship-rings"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16406557_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37820079/2018/03/27/minnesota-team-raises-money-to-buy-championship-rings"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16406557_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>A crowdfunding campaign is helping an eastern Minnesota high school basketball team acquire lasting reminders of their state championship win.</p></span><a class="more" href="/story/37820079/2018/03/27/minnesota-team-raises-money-to-buy-championship-rings"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A crowdfunding campaign is helping an eastern Minnesota high school basketball team acquire lasting reminders of their state championship win.</p></span><a class="more" href="/story/37820079/2018/03/27/minnesota-team-raises-money-to-buy-championship-rings"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-6 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2018-03-27 12:50:50"><h4 class="wnContent headline"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">Update - Fight in NW Rochester apartment ends in five overnight stabbings and a life-threatening assault</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">Update - Fight in NW Rochester apartment ends in five overnight stabbings and a life-threatening assault</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404498_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404498_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>New details in an overnight stabbing that has left six people in the hospital. Rochester police say the first 911 call came from neighbors to the crime scene at 2825 56th Street NW, Apartment&nbsp;A. The call came in around 12:20 Tuesday morning.</p></span><a class="more" href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>New details in an overnight stabbing that has left six people in the hospital. Rochester police say the first 911 call came from neighbors to the crime scene at 2825 56th Street NW, Apartment&nbsp;A. The call came in around 12:20 Tuesday morning.</p></span><a class="more" href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-7 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content="2018-03-27 14:54:34"><h4 class="wnContent headline"><a href="/story/37818681/2018/03/27/new-name-for-the-diocese-of-winona-recognizes-changing-times"><span class="text">New name for the Diocese of Winona recognizes changing times</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37818681/2018/03/27/new-name-for-the-diocese-of-winona-recognizes-changing-times"><span class="text">New name for the Diocese of Winona recognizes changing times</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37818681/2018/03/27/new-name-for-the-diocese-of-winona-recognizes-changing-times"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/13744669_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37818681/2018/03/27/new-name-for-the-diocese-of-winona-recognizes-changing-times"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/13744669_G.png"></a></div><div class="wnContent summary abridged"><span class="text">Out with the old, and in with the new. That's the message from the diocese formerly known as &quot;Winona.&quot;&nbsp;  A congregation of Bishops has decreed that the Diocese of Winona&nbsp;will now be called the Diocese of Winona-Rochester.&nbsp;  In addition, St.&nbsp;John the Evangelist Church of Rochester will be designated as a co-cathedral.&nbsp;  The diocese announced the changes in a news release Tuesday.&nbsp;  &nbsp;According to Bishop John Quinn, Winona was a key location i...</span><a class="more" href="/story/37818681/2018/03/27/new-name-for-the-diocese-of-winona-recognizes-changing-times"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Out with the old, and in with the new. That's the message from the diocese formerly known as &quot;Winona.&quot;&nbsp;  A congregation of Bishops has decreed that the Diocese of Winona&nbsp;will now be called the Diocese of Winona-Rochester.&nbsp;  In addition, St.&nbsp;John the Evangelist Church of Rochester will be designated as a co-cathedral.&nbsp;  The diocese announced the changes in a news release Tuesday.&nbsp;  &nbsp;According to Bishop John Quinn, Winona was a key location i...</span><a class="more" href="/story/37818681/2018/03/27/new-name-for-the-diocese-of-winona-recognizes-changing-times"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-8 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2018-03-26 22:15:00"><h4 class="wnContent headline"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">UPDATE: Authorities identify victim in Blooming Prairie homicide</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">UPDATE: Authorities identify victim in Blooming Prairie homicide</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16405275_G.jpg" title="Lori Riess, 56, is a person of interest in his murder. If seen, call 911" alt="Lori Riess, 56, is a person of interest in his murder. If seen, call 911"></a><span class="caption left width90"><span class="text">Lori Riess, 56, is a person of interest in his murder. If seen, call 911</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16405275_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Southern Minnesota Regional Medical Examiner's Office has identified the victim of a homicide that took place in rural Dodge County on Friday, March 23. They say David Riess, 54, died at his home on 75859 US Hwy 18 from multiple gunshot wounds. Law enforcement is looking for Reiss' wife, 56-year-old Lois Ann Riess, as a person of interest in his murder.&nbsp;</p></span><a class="more" href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Southern Minnesota Regional Medical Examiner's Office has identified the victim of a homicide that took place in rural Dodge County on Friday, March 23. They say David Riess, 54, died at his home on 75859 US Hwy 18 from multiple gunshot wounds. Law enforcement is looking for Reiss' wife, 56-year-old Lois Ann Riess, as a person of interest in his murder.&nbsp;</p></span><a class="more" href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-9 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content="2018-03-27 13:54:42"><h4 class="wnContent headline"><a href="/story/37818034/2018/03/27/ride-into-the-future-at-this-transportation-career-fair-in-winona"><span class="text">Ride into the future at this transportation career fair in Winona</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37818034/2018/03/27/ride-into-the-future-at-this-transportation-career-fair-in-winona"><span class="text">Ride into the future at this transportation career fair in Winona</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37818034/2018/03/27/ride-into-the-future-at-this-transportation-career-fair-in-winona"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16359643_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37818034/2018/03/27/ride-into-the-future-at-this-transportation-career-fair-in-winona"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16359643_G.png"></a></div><div class="wnContent summary abridged"><span class="text">An industry badly needing workers is the focus of a career fair tonight in Winona.  Minnesota State College Southeast hosts its fourth annual Transportation Career Night.  Four college programs will be highlighted: auto body collision technology, automotive tech, diesel maintenance, and truck driving.&nbsp;  Last week, KTTC shared a report that found the truck driving industry has close to 900,000&nbsp;openings around the country.&nbsp;  At Tuesday's fair, meet industry reps while try...</span><a class="more" href="/story/37818034/2018/03/27/ride-into-the-future-at-this-transportation-career-fair-in-winona"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">An industry badly needing workers is the focus of a career fair tonight in Winona.  Minnesota State College Southeast hosts its fourth annual Transportation Career Night.  Four college programs will be highlighted: auto body collision technology, automotive tech, diesel maintenance, and truck driving.&nbsp;  Last week, KTTC shared a report that found the truck driving industry has close to 900,000&nbsp;openings around the country.&nbsp;  At Tuesday's fair, meet industry reps while try...</span><a class="more" href="/story/37818034/2018/03/27/ride-into-the-future-at-this-transportation-career-fair-in-winona"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-10 even displaySizeId-7 even-7 collapsed last"><meta content="News"><meta content="2018-03-27 13:40:05"><h4 class="wnContent headline"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">Court documents say boyfriend admitted firing fatal shot</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">Court documents say boyfriend admitted firing fatal shot</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404882_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404882_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>Court documents say the boyfriend of a pregnant teenager admitted to fatally shooting her in St. Paul, but said it was an accident.</p></span><a class="more" href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Court documents say the boyfriend of a pregnant teenager admitted to fatally shooting her in St. Paul, but said it was an accident.</p></span><a class="more" href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId78');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 4 (78)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Promo Box - Col 4B (25)--><div class="wnBlock displaySize displaySizeId25 promoBox" id="DisplaySizeId25"><ul class="wnGroup contentGroup odd last"><li class="wnItem header"><h3><span class="text sectionTitle">Most Popular Stories</span><span class="text abridgedHeadline">Most Popular Stories</span><a class="wnContent more" href="/mostpopularstory"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature News story priority-1 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2018-03-27 12:50:50"><h4 class="wnContent headline"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">Update - Fight in NW Rochester apartment ends in five overnight stabbings and a life-threatening assault</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">Update - Fight in NW Rochester apartment ends in five overnight stabbings and a life-threatening assault</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404498_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404498_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>New details in an overnight stabbing that has left six people in the hospital. Rochester police say the first 911 call came from neighbors to the crime scene at 2825 56th Street NW, Apartment&nbsp;A. The call came in around 12:20 Tuesday morning.</p></span><a class="more" href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>New details in an overnight stabbing that has left six people in the hospital. Rochester police say the first 911 call came from neighbors to the crime scene at 2825 56th Street NW, Apartment&nbsp;A. The call came in around 12:20 Tuesday morning.</p></span><a class="more" href="/story/37817267/2018/03/27/update-fight-in-nw-rochester-apartment-ends-in-five-overnight-stabbings-and-a-life-threatening-assault"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-10 even-10"><meta content="News"><meta content="2018-03-26 22:15:00"><h4 class="wnContent headline"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">UPDATE: Authorities identify victim in Blooming Prairie homicide</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">UPDATE: Authorities identify victim in Blooming Prairie homicide</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16405275_G.jpg" title="Lori Riess, 56, is a person of interest in his murder. If seen, call 911" alt="Lori Riess, 56, is a person of interest in his murder. If seen, call 911"></a><span class="caption left width90"><span class="text">Lori Riess, 56, is a person of interest in his murder. If seen, call 911</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16405275_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Southern Minnesota Regional Medical Examiner's Office has identified the victim of a homicide that took place in rural Dodge County on Friday, March 23. They say David Riess, 54, died at his home on 75859 US Hwy 18 from multiple gunshot wounds. Law enforcement is looking for Reiss' wife, 56-year-old Lois Ann Riess, as a person of interest in his murder.&nbsp;</p></span><a class="more" href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Southern Minnesota Regional Medical Examiner's Office has identified the victim of a homicide that took place in rural Dodge County on Friday, March 23. They say David Riess, 54, died at his home on 75859 US Hwy 18 from multiple gunshot wounds. Law enforcement is looking for Reiss' wife, 56-year-old Lois Ann Riess, as a person of interest in his murder.&nbsp;</p></span><a class="more" href="/story/37812914/2018/03/26/update-authorities-identify-victim-in-blooming-prairie-homicide"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2018-03-26 17:18:55"><h4 class="wnContent headline"><a href="/story/37810405/2018/03/26/man-arrested-for-alleged-sexual-intercourse-with-14-year-old-boy"><span class="text">Man arrested for alleged sexual intercourse with 14-year-old boy</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37810405/2018/03/26/man-arrested-for-alleged-sexual-intercourse-with-14-year-old-boy"><span class="text">Man arrested for alleged sexual intercourse with 14-year-old boy</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37810405/2018/03/26/man-arrested-for-alleged-sexual-intercourse-with-14-year-old-boy"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16398117_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37810405/2018/03/26/man-arrested-for-alleged-sexual-intercourse-with-14-year-old-boy"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16398117_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A match on the the mobile networking app Grindr landed a man in hot water with the law after he met with a 14-year-old male for a sexual encounter.&nbsp;&nbsp;</p></span><a class="more" href="/story/37810405/2018/03/26/man-arrested-for-alleged-sexual-intercourse-with-14-year-old-boy"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A match on the the mobile networking app Grindr landed a man in hot water with the law after he met with a 14-year-old male for a sexual encounter.&nbsp;&nbsp;</p></span><a class="more" href="/story/37810405/2018/03/26/man-arrested-for-alleged-sexual-intercourse-with-14-year-old-boy"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-10 even-10"><meta content="News"><meta content="2018-03-27 13:26:01"><h4 class="wnContent headline"><a href="/story/37817647/2018/03/27/5-minnesota-prison-workers-injured-in-another-incident"><span class="text">5 Minnesota prison workers injured in another incident</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37817647/2018/03/27/5-minnesota-prison-workers-injured-in-another-incident"><span class="text">5 Minnesota prison workers injured in another incident</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37817647/2018/03/27/5-minnesota-prison-workers-injured-in-another-incident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404709_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37817647/2018/03/27/5-minnesota-prison-workers-injured-in-another-incident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404709_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>State corrections officials say five more workers have been injured at the Minnesota Correction Facility-Oak Park Heights.</p></span><a class="more" href="/story/37817647/2018/03/27/5-minnesota-prison-workers-injured-in-another-incident"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>State corrections officials say five more workers have been injured at the Minnesota Correction Facility-Oak Park Heights.</p></span><a class="more" href="/story/37817647/2018/03/27/5-minnesota-prison-workers-injured-in-another-incident"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-5 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2018-03-27 04:19:43"><h4 class="wnContent headline"><a href="/story/37814770/2018/03/27/fentanyl-in-princes-body-was-exceedingly-high"><span class="text">Fentanyl in Prince's body was exceedingly high</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37814770/2018/03/27/fentanyl-in-princes-body-was-exceedingly-high"><span class="text">Fentanyl in Prince's body was exceedingly high</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37814770/2018/03/27/fentanyl-in-princes-body-was-exceedingly-high"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/15343911_G.jpg" title="MGN: Online" alt="MGN: Online"></a><span class="caption left width90"><span class="text">MGN: Online</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37814770/2018/03/27/fentanyl-in-princes-body-was-exceedingly-high"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/15343911_G.jpg" title="MGN: Online" alt="MGN: Online"></a><span class="caption left width90"><span class="text">MGN: Online</span></span></div><div class="wnContent summary abridged"><span class="text"><p>Prince was 57 when he was found alone and unresponsive in an elevator at his Paisley Park estate on April 21, 2016. Public data released six weeks later showed he died of an accidental fentanyl overdose.</p></span><a class="more" href="/story/37814770/2018/03/27/fentanyl-in-princes-body-was-exceedingly-high"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Prince was 57 when he was found alone and unresponsive in an elevator at his Paisley Park estate on April 21, 2016. Public data released six weeks later showed he died of an accidental fentanyl overdose.</p></span><a class="more" href="/story/37814770/2018/03/27/fentanyl-in-princes-body-was-exceedingly-high"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-6 even displaySizeId-10 even-10"><meta content="News"><meta content="2018-03-27 03:52:52"><h4 class="wnContent headline"><a href="/story/37814624/2018/03/26/mayo-civic-center-financial-forecast-projects-budget-deficit"><span class="text">Mayo Civic Center financial forecast projects budget deficit</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/37814624/2018/03/26/mayo-civic-center-financial-forecast-projects-budget-deficit"><span class="text">Mayo Civic Center financial forecast projects budget deficit</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/37814624/2018/03/26/mayo-civic-center-financial-forecast-projects-budget-deficit"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16402546_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37814624/2018/03/26/mayo-civic-center-financial-forecast-projects-budget-deficit"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16402546_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>84-million dollars later, the Mayo Civic Center expansion and renovation in Rochester was expected to draw bigger and flashier events to town, bringing in revenue and helping position Rochester as the medical destination.&nbsp;</p></span><a class="more" href="/story/37814624/2018/03/26/mayo-civic-center-financial-forecast-projects-budget-deficit"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>84-million dollars later, the Mayo Civic Center expansion and renovation in Rochester was expected to draw bigger and flashier events to town, bringing in revenue and helping position Rochester as the medical destination.&nbsp;</p></span><a class="more" href="/story/37814624/2018/03/26/mayo-civic-center-financial-forecast-projects-budget-deficit"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-7 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2018-03-27 13:40:05"><h4 class="wnContent headline"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">Court documents say boyfriend admitted firing fatal shot</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">Court documents say boyfriend admitted firing fatal shot</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404882_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/16404882_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>Court documents say the boyfriend of a pregnant teenager admitted to fatally shooting her in St. Paul, but said it was an accident.</p></span><a class="more" href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Court documents say the boyfriend of a pregnant teenager admitted to fatally shooting her in St. Paul, but said it was an accident.</p></span><a class="more" href="/story/37817809/2018/03/27/court-documents-say-boyfriend-admitted-firing-fatal-shot"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-8 even displaySizeId-10 even-10 last"><meta content="News - AP-National"><meta content="2018-03-27 04:20:16"><h4 class="wnContent headline"><a href="/story/37814774/lawmaker-withdraws-anti-porn-bill-citing-dubious-origins"><span class="text">Lawmaker withdraws anti-porn bill, citing 'dubious origins'</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/37814774/lawmaker-withdraws-anti-porn-bill-citing-dubious-origins"><span class="text">Lawmaker withdraws anti-porn bill, citing 'dubious origins'</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Tuesday, March 27 2018 6:15 PM EDT</span><span class="wnContent timestamp gmttime">2018-03-27 22:15:47 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/37814774/lawmaker-withdraws-anti-porn-bill-citing-dubious-origins"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16402785_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/37814774/lawmaker-withdraws-anti-porn-bill-citing-dubious-origins"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/16402785_G.jpg" title="(Metropolitan Nashville Police Department via AP). This 2014 booking photo released by the Metropolitan Nashville Police Department shows Mark &quot;Chris&quot; Sevier after his arrest for harassment threats against country singer John Rich. A bill scheduled for..." alt="(Metropolitan Nashville Police Department via AP). This 2014 booking photo released by the Metropolitan Nashville Police Department shows Mark &quot;Chris&quot; Sevier after his arrest for harassment threats against country singer John Rich. A bill scheduled for..."></a><span class="caption left width90"><span class="text">(Metropolitan Nashville Police Department via AP). This 2014 booking photo released by the Metropolitan Nashville Police Department shows Mark "Chris" Sevier after his arrest for harassment threats against country singer John Rich. A bill scheduled for...</span></span></div><div class="wnContent summary abridged"><span class="text">A man who tried to marry his laptop in a legal fight against same-sex marriage is popping up in states across the country as he pushes legislation to require an internet block on pornography and human trafficking...</span><a class="more" href="/story/37814774/lawmaker-withdraws-anti-porn-bill-citing-dubious-origins"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">A man who tried to marry his laptop in a legal fight against same-sex marriage is popping up in states across the country as he pushes legislation to require an internet block on pornography and human trafficking websites.</span><a class="more" href="/story/37814774/lawmaker-withdraws-anti-porn-bill-citing-dubious-origins"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId25');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Promo Box - Col 4B (25)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://KTTC.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText"><div class="footer-top clearfix">
	<div class="footer-search clearfix">
		<div class="footer-search-text">Can't Find Something?</div>
		<div class="footer-search-box">
			<form action="/search" method="get" onsubmit="return wnValidateSearchTerm(this, 0)">
	        	<input type="hidden" name="vendor" value="ez">
	        	<input class="footer-textbox" type="text" name="qu" value="" placeholder="Search">
	       		<input class="footer-submit" type="submit" value="Go">
	    	</form>
    	</div>
	</div>
	<div class="station-logo"></div>
	<div class="station-info">
        <p class='address'><strong>KTTC</strong><br />
         	6301 Bandel Road NW, Rochester, MN 55901<br />
        	Switchboard: 507-288-4444<br />
		News tips: 507-280-5125 or <a href="mailto:news@kttc.com">news@kttc.com</a><br />
         	         	<div>
	         	<a class="info" href="http://www.kttc.com/category/134180/kttc-jobs">Careers</a>
	         	<a class="info" href="http://www.kttc.com/link/781956/advertise-with-kttc">Advertise with us</a>
         		<a class="info" href="https://xprspay.ipayxepay.net/xprspay/qmi/index.jsp">Advertiser Services </a>
		</div>
         	<div>
	         	<a class="info" target="_blank" href="https://publicfiles.fcc.gov/tv-profile/kttc">FCC Public File</a>
	         	<a class="info" target="_blank" href="http://www.kttc.com/link/739878/eeo-report">EEO Report</a>
	         	<a class="info" href="http://www.kttc.com/story/35022866/2017/03/29/kttc-closed-caption-contact">Closed Captioning Contact</a>
         	</div> 
         	      	        	
        </p>
	</div>
</div>
<div class="footer-middle clearfix"></div>
<div class="footer-bottom clearfix">
	<div class="inner">
		<div class="copyrightText">
			<a id="wnLogo" href="http://www.worldnow.com"><img src="http://ftpcontent.worldnow.com/wncorp/logos/worldnow_white.png" id="wn"></a>
	    	<div class="text">
				All content &copy; Copyright 2000 - 2018 KTTC. All Rights Reserved. For more information on this site, please read our <a href="/story/15534331/privacy-policy">Privacy Policy</a>, <a href="/story/15534195/terms-of-service">Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.
	    	</div>
	    	<div class="clear"></div>       
		</div>
	</div>
</div></div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>