<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script src="//worldnow-d.openx.net/w/1.0/jstag?nc=43459271-wnow"></script><script class="kxct" data-id="qv9k973w2" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9k973w2";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>Dayton expresses support for police after blowback - KTTC Rochester, Austin, Mason City News, Weather and Sports</title>
<meta name="Description" content="Gov. Mark Dayton is stressing his support for police officers after facing backlash for his handling of the death of a black man shot and killed by an officer last year.  Thursday was the first ann..."><meta name="KEYWORDS" content="kttc,rochester,minnesota,mn,news,news center,10,breaking news,local news,mayo clinic,ibm,austin,albert lea,winona,mason city&#xD;&#xA;"><meta name="news_keywords" content="kttc,rochester,minnesota,mn,news,news center,10,breaking news,local news,mayo clinic,ibm,austin,albert lea,winona,mason city&#xD;&#xA;"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/07/07"><meta name="owner" content="KTTC"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="release-VIDEO-577-Pagination.6"><meta name="wn-base" content="IIS05"><meta name="wnreadableurl" content="dayton-expresses-support-for-police-after-blowback"><meta name="wnreadabledate" content="2017/07/07"><meta property="og:title" content="Dayton expresses support for police after blowback"><meta property="og:type" content="article"><meta property="og:url" content="http://www.kttc.com/story/35837191/2017/07/Friday/dayton-expresses-support-for-police-after-blowback"><meta property="og:image" content="http://KTTC.images.worldnow.com/images/7829410_G.jpg"><meta property="og:description" content="Gov. Mark Dayton is stressing his support for police officers after facing backlash for his handling of the death of a black man shot and killed by an officer last year.  Thursday was the first ann..."><link rel="canonical" href="http://www.kttc.com/story/35837191/2017/07/Friday/dayton-expresses-support-for-police-after-blowback"><meta name="author" content="KTTC Newsroom"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Dayton expresses support for police after blowback"><meta name="twitter:description" content="Gov. Mark Dayton is stressing his support for police officers after facing backlash for his handling of the death of a black man shot and killed by an officer last year.  Thursday was the first ann..."><meta name="twitter:image" content="http://KTTC.images.worldnow.com/images/7829410_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta name='verify-v1' content='RdB/QY3JvkKlmIVJQYs5oBhteC0S/IPXcq/9A/VaHes=' /><meta name="google-site-verification" content="bMnk8RWoHmafMEoMBDFXckKRNku8S1RzP7St5gp_7Lo" /><!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=release-VIDEO-577-Pagination.6_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://KTTC.images.worldnow.com/interface/css/container-e.css?ver=2017-06-12%2017%3A08%3A15_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_release-VIDEO-577-Pagination.6" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=release-VIDEO-577-Pagination.6"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=release-VIDEO-577-Pagination.6"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=release-VIDEO-577-Pagination.6"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu1348 UL
                    , #menu1348 .wnHorizontal { background-color: #eaeaea; font-family: Arial; font-size: 11px; font-weight: 700; color: #ffffff; }
                #menu1348 A,
                    #menu1348 LI.wnOn .wnSublevel A,
                    #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 11px; font-weight: 700; color: #ffffff; }
                #menu1348 .wnHorizontal .wnDynamic .wnMenuTypeText
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { padding-right: 15px; }
                #menu1348
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_tridown.gif') no-repeat 98% 50%; }
                #menu1348
                        .wnLevel1 LI.wnHasSublevel .wnLevel2 .wnMiddle SPAN { background: none; }
            #menu1348 UL LI.wnOn { background-color: #eaeaea; color: #000000; }
                    #menu1348 LI.wnOn A,
                        #menu1348 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu1348 .wnSublevel { background-color: #eaeaea; color: #000000; }
                #menu1348 LI.wnOn .wnSublevel A,
                    #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { color: #000000; }
                #menu1348 .wnSublevel A { border : 1px #eaeaea solid; border-top: none; }
                        #menu1348 .wnSublevel .wnFirstNode { border-top : 1px #eaeaea solid; }
                        #menu1348 .wnHorizontal .wnDynamic .wnMenuTypeText .wnSublevel LI.wnHasSublevel A { padding-right: 9px; }
                #menu1348 .wnSublevel LI.wnHasSublevel A { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_tri.gif') no-repeat 98% 50%; }
                #menu1348 .wnSublevel LI.wnHasSublevel .wnLevel3 A { background: none; }
            #menu1348 .wnSublevel LI.wnOn {  color: #142c8e; }
                    #menu1348 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu1348 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #142c8e; }
                    #menu1348 .wnLeft { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 6px; }
                    #menu1348 LI.wnOn .wnLeft { background-image: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu1348 .wnRight { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 6px; }
                    #menu1348 LI.wnOn .wnRight { background-image: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu1348 .wnRight .wnMiddle { background: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu1348 LI.wnOn .wnMiddle { background-image: url('http://KTTC.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'KTTC',
            affiliateId : '720',
            baseUrl : 'www.kttc.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '44',mdPartnerDomain : 'http://dub.kttc.com'},
            registrationId : '557026',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://KTTC.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='release-VIDEO-577-Pagination.6';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='KTTC';
wng_pageInfo.ownerAffiliateId=parseInt('720',10);
wng_pageInfo.containerId=parseInt('35837191',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='News';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback';
wng_pageInfo.content_authors='KTTC Newsroom';
wng_pageInfo.headline='Dayton expresses support for police after blowback';
wng_pageInfo.pageTitle='Dayton expresses support for police after blowback - KTTC Rochester, Austin, Mason City News, Weather and Sports';
wng_pageInfo.pageTitleTag='KTTC Rochester, Austin, Mason City News, Weather and Sports';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffKTTC';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KTTC'},width:468,height:60,wncc:"News",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KTTC'},width:468,height:60,wncc:"News",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:728,height:90,wncc:"News",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:300,height:250,wncc:"News",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["44"]={id:"44",wnsz:"44",ownerinfo:{oldformat:1,owner:'nat',split:'100',type:'inline',aff:'KTTC'},width:300,height:75,wncc:"News",parent:"WNAd44",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:728,height:90,wncc:"News",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_47 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KTTC'},width:300,height:250,wncc:"News",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_63 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
</script>
<script type="text/javascript" src="http://KTTC.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-06-12%2017%3A08%3A15_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/KTTC.config.js?ver=release-VIDEO-577-Pagination.6_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=release-VIDEO-577-Pagination.6_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><script language='JavaScript1.1' src='//pixel.mathtag.com/event/js?mt_id=1013608&mt_adid=163437&v1=&v2=&v3=&s1=&s2=&s3='></script><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script><script type="text/javascript" src="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/revenue/js/storyzoom/storyzoom-complete.css" /><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Roboto:400,700|Roboto+Condensed:400,700"><link type="text/css" rel="stylesheet" href="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/custom-master.css"><link type="text/css" rel="stylesheet" href="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/kttc/custom.css"><script src="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/custom-master.js"></script><script src="http://ftpcontent.worldnow.com/professionalservices/clients/quincy/kttc/custom.js"></script></head><body id="WNAffKTTC" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-91' ,"dma":'153' ,"group":'Quincy'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd41" class="wnad wnad41">
<script>wnad_41.load();</script></div>
<!--END wnAdSize-->
<h1>Dayton expresses support for police after blowback - KTTC Rochester, Austin, Mason City News, Weather and Sports</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/search"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google-logo.gif' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://KTTC.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://KTTC.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu1348" class="wnMainMenu"><div class="wnHorizontal"><div class="wnDynamic"><div class="wnMenuTypeText"><ul class="wnLevel1" id="submenu1348"><li class="wnFirstNode" id="menu1348_1-C123673"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/">HOME</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_1-C123673"><li class="wnFirstNode" id="menu1348_1_1-S30242200"><span><a href="/story/30242200/2015/10/12/contact-kttc">Contact KTTC</a></span></li><li class="" id="menu1348_1_2-C131449"><span><a href="/category/131449/about-us">ABOUT US</a></span></li><li class="" id="menu1348_1_3-C134180"><span><a href="/category/134180/kttc-jobs">KTTC Jobs</a></span></li><li class="" id="menu1348_1_4-L694740"><span><a href="javascript:OpenWin('http://share.kttc.com||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Share photos and videos with us</a></span></li><li class="" id="menu1348_1_5-C134984"><span><a href="/category/134984/kttc-viewer-survey">KTTC Viewer Survey</a></span></li><li class="" id="menu1348_1_6-C163354"><span><a href="/category/163354/business-connections">Business Connections</a></span></li><li class="" id="menu1348_1_7-L481961"><span><a href="https://xprspay.ipayxepay.net/xprspay/qmi/index.jsp">Advertiser Services</a></span></li></ul></li><li class="" id="menu1348_2-C123676"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/123676/news">NEWS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_2-C123676"><li class="wnFirstNode" id="menu1348_2_1-C50681"><span><a href="/category/50681/minnesota-headlines">Minnesota Headlines</a></span></li><li class="" id="menu1348_2_2-C50694"><span><a href="/category/50694/iowa-headlines">Iowa Headlines</a></span></li><li class="" id="menu1348_2_3-C132472"><span><a href="/category/132472/health-beat">Health Beat</a></span></li><li class="" id="menu1348_2_4-C318331"><span><a href="/category/318331/throwback-thursday">Throwback Thursday </a></span></li><li class="" id="menu1348_2_5-C151577"><span><a href="/category/151577/your-money">Your Money</a></span></li><li class="" id="menu1348_2_6-L713987"><span><a href="http://www.kttc.com/category/68446/lifestyle">Lifestyle</a></span></li><li class="" id="menu1348_2_7-C132494"><span><a href="/category/132494/newscenter-extras">NewsCenter Extras</a></span></li><li class="" id="menu1348_2_8-C131448"><span><a href="/category/131448/links">Links</a></span></li><li class="" id="menu1348_2_9-L569193"><span><a href="http://kttc.tributes.com">Obituaries</a></span></li><li class="" id="menu1348_2_10-S25569165"><span><a href="/story/25569165/2014/05/20/download-the-kttc-news-app">Download the KTTC news app</a></span></li></ul></li><li class="" id="menu1348_3-C123674"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather">WEATHER</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_3-C123674"><li class="wnFirstNode" id="menu1348_3_1-C162320"><span><a href="/category/162320/kttc-interactive-radar">KTTC Interactive Radar</a></span></li><li class="" id="menu1348_3_2-C153919"><span><a href="/category/153919/stormcenter-closings-and-delays">StormCenter Closings and Delays</a></span></li><li class="" id="menu1348_3_3-L313522"><span><a href="javascript:OpenWin('/link/313522/traffic-road-conditions||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Traffic &amp; Road Conditions</a></span></li><li class="" id="menu1348_3_4-C307492"><span><a href="/category/307492/kttc-weather-academy">KTTC Weather Academy</a></span></li><li class="" id="menu1348_3_5-C132833"><span><a href="/category/132833/skycams">Skycams</a></span></li><li class="" id="menu1348_3_6-L476803"><span><a href="javascript:OpenWin('http://addins.kttc.com/blogs/weather/||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">KTTC Weather Blog</a></span></li><li class="" id="menu1348_3_7-S19685197"><span><a href="/story/19685197/weather-app-information">Get the KTTC Precision Weather app</a></span></li><li class="" id="menu1348_3_8-S30259342"><span><a href="/story/30259342/2015/10/14/sign-up-for-kttcs-new-weather-email-plus-breaking-news-email">Sign up for KTTC's new weather email </a></span></li></ul></li><li class="" id="menu1348_4-C123677"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/123677/sports">SPORTS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_4-C123677"><li class="wnFirstNode" id="menu1348_4_1-C313544"><span><a href="/category/313544/kttc-golf-card-2017">KTTC Golf Card 2017</a></span></li><li class="" id="menu1348_4_2-C134846"><span><a href="/category/134846/athlete-of-the-week">Athlete of the Week</a></span></li><li class="" id="menu1348_4_3-C269629"><span><a href="/category/269629/football-forecast">Football Forecast</a></span></li><li class="" id="menu1348_4_4-C178278"><span><a href="/category/178278/weekly-sports-scores">Weekly Sports Scores</a></span></li></ul></li><li class="" id="menu1348_5-C280285"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/280285/slideshows-and-lists">SLIDESHOWS</a></span></span></span></span></li><li class="" id="menu1348_6-C131445"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/131445/video">VIDEO</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_6-C131445"><li class="wnFirstNode" id="menu1348_6_1-L314812"><span><a href="javascript:OpenWin('http://KTTC.images.worldnow.com/library/dc8a8f1f-ada0-4913-b0eb-4dbdd90a5f32.pdf||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Request Video</a></span></li></ul></li><li class="" id="menu1348_7-C123678"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/123678/community">THINGS TO DO</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_7-C123678"><li class="wnFirstNode" id="menu1348_7_1-L785736"><span><a href="javascript:OpenWin('http://www.rochestermn.gov/departments/fire/clock-and-bell-tower||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Bring Back Clock Tower &amp; Bell</a></span></li><li class="" id="menu1348_7_2-C313544"><span><a href="/category/313544/kttc-golf-card-2017">KTTC Golf Card 2017</a></span></li><li class="" id="menu1348_7_3-L755054"><span><a href="javascript:OpenWin('http://www.kttc.com/category/123678/community#/55904-rochester/all/today||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Community Calendar</a></span></li><li class="" id="menu1348_7_4-C131447"><span><a href="/category/131447/contests">Contests</a></span></li><li class="" id="menu1348_7_5-C167146"><span><a href="/category/167146/kttc-pet-of-the-week">KTTC Pet of the Week</a></span></li><li class="" id="menu1348_7_6-C167922"><span><a href="/category/167922/kttc-on-the-road">KTTC 'On the Road'</a></span></li><li class="" id="menu1348_7_7-L747132"><span><a href="http://kttc.upickem.net/engine/Welcome.aspx?contestid=177023">KTTC Young Leaders</a></span></li><li class="" id="menu1348_7_8-L313404"><span><a href="javascript:OpenWin('/link/313404/mr-food||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Mr. Food</a></span></li><li class="" id="menu1348_7_9-S16686978"><span><a href="/story/16686978/kttc-business-spotlight">Business Spotlight</a></span></li><li class="" id="menu1348_7_10-C170573"><span><a href="/category/170573/birthday-spotlight">Birthday Spotlight</a></span></li><li class="" id="menu1348_7_11-C135324"><span><a href="/category/135324/gas-buddy">Gas Buddy</a></span></li></ul></li><li class="" id="menu1348_8-C131446"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/131446/whats-on">WHAT'S ON</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu1348_8-C131446"><li class="wnFirstNode" id="menu1348_8_1-C297536"><span><a href="/category/297536/heroes-icons">Heroes &amp; Icons</a></span></li><li class="" id="menu1348_8_2-L758546"><span><a href="javascript:OpenWin('http://www.kttc.com/category/131446/whats-on||height=768,width=980,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Program Guide</a></span></li><li class="" id="menu1348_8_3-C195218"><span><a href="/category/195218/nbc-programming">NBC Programming</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu1348"></div></div></div></div><div id="spacermenu1348" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu1348', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : false, level1ArrowPadding : '15', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } }, cornerGraphics : { left : ['http://KTTC.images.worldnow.com/images/static/gfx/nav_left_off.gif', 'http://KTTC.images.worldnow.com/images/static/gfx/nav_left_on.gif'] , right: ['http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_off.gif', 'http://KTTC.images.worldnow.com/images/static/gfx/nav_rt_on.gif'] } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
</div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">Dayton expresses support for police after blowback</h3>
<em class="wnDate">Posted: 
<script type="text/javascript">
                                wnRenderDate('Friday, July 7, 2017 7:56 PM EDT', '', false);</script>
</em><noscript><em class="wnDate">Friday, July 7, 2017 7:56 PM EDT</em></noscript><!--END wnDate-->
<style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div id="WNStoryByline" class="bylines wn-row"><div class="byline wn-row"><span class="author">By KTTC Newsroom</span></div></div><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div></div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnRight" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://KTTC.images.worldnow.com/images/7829410_G.jpg" alt="Gov. Mark Dayton" title="Gov. Mark Dayton" border="0" width="180">
<span>Gov. Mark Dayton</span></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated right"><span id="WNStoryDateline">St. Paul, Minn. (AP) -
            </span><p>Gov. Mark Dayton is stressing his support for police officers after facing backlash for his handling of the death of a black man shot and killed by an officer last year.</p><p>Thursday was the first anniversary of the death of 32-year-old Philando Castile. Castile, who was black, was shot and killed by Jeronimo Yanez during a traffic stop last July. Yanez was acquitted of manslaughter last month.</p><p>Dayton gathered with Castile's family members and pushed to name a new police training fund in his memory. Prominent police unions called that suggestion an insult.</p><p>Dayton expressed his confidence in officers after meeting with law enforcement organizations on Friday. Dayton says it's difficult to toe the line between supporting the black community and their calls for police reform and supporting law enforcement.</p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 7-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd44" class="wnad wnad44">
<script>wnad_44.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Headline Box - Col 4 (78)--><div class="wnBlock displaySize displaySizeId78 headlineBox" id="DisplaySizeId78"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Mobile Top Stories</span><a class="wnContent more enabled" href="/category/250927/mobile-top-stories"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature News story priority-1 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2017-07-08 00:18:17"><h4 class="wnContent headline"><a href="/story/35837275/2017/07/07/two-hurt-after-suv-crashes-into-train-in-faribault"><span class="text">Two hurt after SUV crashes into train in Faribault</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837275/2017/07/07/two-hurt-after-suv-crashes-into-train-in-faribault"><span class="text">Two hurt after SUV crashes into train in Faribault</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35837275/2017/07/07/two-hurt-after-suv-crashes-into-train-in-faribault"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14330660_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35837275/2017/07/07/two-hurt-after-suv-crashes-into-train-in-faribault"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14330660_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Two people were hurt when a SUV crashed into a train in Faribault.  The crash happened shortly after 9 a.m. Friday.  Initial investigation indicates a 2011 Infinity SUV, driven by 49-year-old Shan Roehrick, was southbound on 2nd Ave NE&nbsp;when it struck a train boxcar backing across 2nd Avenue NW.  Roehrick, the SUV's driver, was the only person inside the vehicle.&nbsp;  A railroad employee on board the train, 26-year-old Damien North-O'Brien, was injured along with Roehrick.  Both...</span><a class="more" href="/story/35837275/2017/07/07/two-hurt-after-suv-crashes-into-train-in-faribault"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Two people were hurt when a SUV crashed into a train in Faribault.  The crash happened shortly after 9 a.m. Friday.  Initial investigation indicates a 2011 Infinity SUV, driven by 49-year-old Shan Roehrick, was southbound on 2nd Ave NE&nbsp;when it struck a train boxcar backing across 2nd Avenue NW.  Roehrick, the SUV's driver, was the only person inside the vehicle.&nbsp;  A railroad employee on board the train, 26-year-old Damien North-O'Brien, was injured along with Roehrick.  Both...</span><a class="more" href="/story/35837275/2017/07/07/two-hurt-after-suv-crashes-into-train-in-faribault"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-7 even-7"><meta content="News"><meta content="2017-07-07 23:56:54"><h4 class="wnContent headline"><a href="/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback"><span class="text">Dayton expresses support for police after blowback</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback"><span class="text">Dayton expresses support for police after blowback</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/7829410_G.jpg" title="Gov. Mark Dayton" alt="Gov. Mark Dayton"></a><span class="caption left width90"><span class="text">Gov. Mark Dayton</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/7829410_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Gov. Mark Dayton is stressing his support for police officers after facing backlash for his handling of the death of a black man shot and killed by an officer last year.  Thursday was the first anniversary of the death of 32-year-old Philando Castile. Castile, who was black, was shot and killed by Jeronimo Yanez during a traffic stop last July. Yanez was acquitted of manslaughter last month.  Dayton gathered with Castile's family members and pushed to name a new police training fund i...</span><a class="more" href="/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Gov. Mark Dayton is stressing his support for police officers after facing backlash for his handling of the death of a black man shot and killed by an officer last year.  Thursday was the first anniversary of the death of 32-year-old Philando Castile. Castile, who was black, was shot and killed by Jeronimo Yanez during a traffic stop last July. Yanez was acquitted of manslaughter last month.  Dayton gathered with Castile's family members and pushed to name a new police training fund i...</span><a class="more" href="/story/35837191/2017/07/07/dayton-expresses-support-for-police-after-blowback"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2017-07-07 23:53:57"><h4 class="wnContent headline"><a href="/story/35837175/2017/07/07/protesters-to-greet-dayton-when-he-fishes-on-mille-lacs-lake"><span class="text">Protesters to greet Dayton when he fishes on Mille Lacs Lake</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837175/2017/07/07/protesters-to-greet-dayton-when-he-fishes-on-mille-lacs-lake"><span class="text">Protesters to greet Dayton when he fishes on Mille Lacs Lake</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35837175/2017/07/07/protesters-to-greet-dayton-when-he-fishes-on-mille-lacs-lake"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/13994115_G.jpg" title="Gov. Mark Dayton (DFL) held a press conference Friday afternoon to answer questions about the 2017 legislative session" alt="Gov. Mark Dayton (DFL) held a press conference Friday afternoon to answer questions about the 2017 legislative session"></a><span class="caption left width90"><span class="text">Gov. Mark Dayton (DFL) held a press conference Friday afternoon to answer questions about the 2017 legislative session</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35837175/2017/07/07/protesters-to-greet-dayton-when-he-fishes-on-mille-lacs-lake"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/13994115_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Protesters will be on Mille Lacs Lake to greet Gov. Mark Dayton when he goes bass fishing Saturday.  Walleye fishing -- even catch and release -- is prohibited on the big lake for the next three weeks. The Department of Natural Resources is trying to protect the lake's struggling walleye population from hooking mortality, the problem of fish dying after they're released, which gets worse in warm weather.  Dayton will set out from Fisher's Resort on Saturday to promote Mille Lacs' outs...</span><a class="more" href="/story/35837175/2017/07/07/protesters-to-greet-dayton-when-he-fishes-on-mille-lacs-lake"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Protesters will be on Mille Lacs Lake to greet Gov. Mark Dayton when he goes bass fishing Saturday.  Walleye fishing -- even catch and release -- is prohibited on the big lake for the next three weeks. The Department of Natural Resources is trying to protect the lake's struggling walleye population from hooking mortality, the problem of fish dying after they're released, which gets worse in warm weather.  Dayton will set out from Fisher's Resort on Saturday to promote Mille Lacs' outs...</span><a class="more" href="/story/35837175/2017/07/07/protesters-to-greet-dayton-when-he-fishes-on-mille-lacs-lake"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-07-07 23:51:08"><h4 class="wnContent headline"><a href="/story/35837165/2017/07/07/childrens-minnesota-blue-cross-settle-contract-dispute"><span class="text">Children's Minnesota, Blue Cross settle contract dispute</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837165/2017/07/07/childrens-minnesota-blue-cross-settle-contract-dispute"><span class="text">Children's Minnesota, Blue Cross settle contract dispute</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35837165/2017/07/07/childrens-minnesota-blue-cross-settle-contract-dispute"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/9447475_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35837165/2017/07/07/childrens-minnesota-blue-cross-settle-contract-dispute"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/9447475_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A Minnesota health insurance company and the state's largest pediatric hospital system have settled a stalemate affecting about 66,000 patients. Children's Minnesota and Eagan-based Blue Cross and Blue Shield of Minnesota announced a new three-year contract agreement Friday. The two sides could not make a deal before Wednesday's deadline, making Children's Minnesota an out-of-network provider for Blue Cross patients. The new agreement restores in-network access to Children's Minnes...</p> </span><a class="more" href="/story/35837165/2017/07/07/childrens-minnesota-blue-cross-settle-contract-dispute"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A Minnesota health insurance company and the state's largest pediatric hospital system have settled a stalemate affecting about 66,000 patients. Children's Minnesota and Eagan-based Blue Cross and Blue Shield of Minnesota announced a new three-year contract agreement Friday. The two sides could not make a deal before Wednesday's deadline, making Children's Minnesota an out-of-network provider for Blue Cross patients. The new agreement restores in-network access to Children's Minnes...</p></span><a class="more" href="/story/35837165/2017/07/07/childrens-minnesota-blue-cross-settle-contract-dispute"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-5 odd displaySizeId-7 odd-7 collapsed"><meta content="News - AP-National"><meta content="2017-07-07 10:57:19"><h4 class="wnContent headline"><a href="/story/35831748/g-20-clashes-leave-dozens-of-officers-and-activists-injured"><span class="text">G-20 clashes leave dozens of officers and activists injured</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35831748/g-20-clashes-leave-dozens-of-officers-and-activists-injured"><span class="text">G-20 clashes leave dozens of officers and activists injured</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 7:48 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 23:48:01 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35831748/g-20-clashes-leave-dozens-of-officers-and-activists-injured"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/14324204_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35831748/g-20-clashes-leave-dozens-of-officers-and-activists-injured"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/14324204_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Anti-globalization activists set dozens of cars ablaze and tried to block leaders' delegations from entering the grounds of the Group of 20 summit Friday, a second day of protests as the meeting got underway in the...</span><a class="more" href="/story/35831748/g-20-clashes-leave-dozens-of-officers-and-activists-injured"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Anti-globalization activists set dozens of cars ablaze and tried to block leaders' delegations from entering the grounds of the Group of 20 summit Friday, a second day of protests as the meeting got underway in the German port city of Hamburg.</span><a class="more" href="/story/35831748/g-20-clashes-leave-dozens-of-officers-and-activists-injured"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-6 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-07-07 20:01:36"><h4 class="wnContent headline"><a href="/story/35835588/2017/07/07/drive-in-movie-theater-returns-to-spring-valley-after-nearly-30-years"><span class="text">On The Road: Drive-in movie theater returns to Spring Valley after nearly 30 years</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35835588/2017/07/07/drive-in-movie-theater-returns-to-spring-valley-after-nearly-30-years"><span class="text">On The Road: Drive-in movie theater returns to Spring Valley after nearly 30 years</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35835588/2017/07/07/drive-in-movie-theater-returns-to-spring-valley-after-nearly-30-years"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14328337_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35835588/2017/07/07/drive-in-movie-theater-returns-to-spring-valley-after-nearly-30-years"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14328337_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>History repeats itself in Spring Valley, allowing some to re-live their teenage years.&nbsp;On Saturday, Spring Valley is home to a revival of the drive-in movie theater, something to be passed on from one generation to the next.&nbsp;</p></span><a class="more" href="/story/35835588/2017/07/07/drive-in-movie-theater-returns-to-spring-valley-after-nearly-30-years"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>History repeats itself in Spring Valley, allowing some to re-live their teenage years.&nbsp;On Saturday, Spring Valley is home to a revival of the drive-in movie theater, something to be passed on from one generation to the next.&nbsp;</p></span><a class="more" href="/story/35835588/2017/07/07/drive-in-movie-theater-returns-to-spring-valley-after-nearly-30-years"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-7 odd displaySizeId-7 odd-7 collapsed"><meta content="News - AP-National"><meta content="2017-07-07 08:05:36"><h4 class="wnContent headline"><a href="/story/35831000/trump-meets-putin-talk-of-positive-results-not-of-election"><span class="text">Trump meets Putin: Talk of positive results, not of election</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35831000/trump-meets-putin-talk-of-positive-results-not-of-election"><span class="text">Trump meets Putin: Talk of positive results, not of election</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 2:19 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-07 18:19:53 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35831000/trump-meets-putin-talk-of-positive-results-not-of-election"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/14323480_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35831000/trump-meets-putin-talk-of-positive-results-not-of-election"><img border="0" width="90" data-path="http://images.worldnow.com/AP/images/14323480_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">After weeks of build-up, President Donald Trump and Russian President Vladimir Putin will meet at an international summit in Germany.</span><a class="more" href="/story/35831000/trump-meets-putin-talk-of-positive-results-not-of-election"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">After weeks of build-up, President Donald Trump and Russian President Vladimir Putin will meet at an international summit in Germany.</span><a class="more" href="/story/35831000/trump-meets-putin-talk-of-positive-results-not-of-election"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-8 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-07-07 14:07:30"><h4 class="wnContent headline"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">UPDATE: Two dogs reported stolen in Rochester returned to owner</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">UPDATE: Two dogs reported stolen in Rochester returned to owner</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/12719128_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/12719128_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Police are investigating after two dogs were stolen from a southeast Rochester home.&nbsp; Rochester Police said a homeowner on the 900 block of 17&frac12; Street SE let her two chihuahuas out into the fenced backyard sometime around 6:30 a.m. and 7 p.m. on Thursday.&nbsp;</p> </span><a class="more" href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Police are investigating after two dogs were stolen from a southeast Rochester home.&nbsp; Rochester Police said a homeowner on the 900 block of 17&frac12; Street SE let her two chihuahuas out into the fenced backyard sometime around 6:30 a.m. and 7 p.m. on Thursday.&nbsp;</p></span><a class="more" href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-9 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content="2017-07-07 14:31:08"><h4 class="wnContent headline"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">Three arrested at neighboring Rochester homes as part of drug investigation</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">Three arrested at neighboring Rochester homes as part of drug investigation</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325638_G.jpg" title="Samantha Bennett, Laurie Abell and Terry Heggs" alt="Samantha Bennett, Laurie Abell and Terry Heggs"></a><span class="caption left width90"><span class="text">Samantha Bennett, Laurie Abell and Terry Heggs</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325638_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Three people are facing drug charges after search warrants were carried out at neighboring Rochester homes.&nbsp; Rochester Police said the busts were part of an ongoing investigation by the Criminal Interdiction Unit.</p></span><a class="more" href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Three people are facing drug charges after search warrants were carried out at neighboring Rochester homes.&nbsp; Rochester Police said the busts were part of an ongoing investigation by the Criminal Interdiction Unit.</p></span><a class="more" href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-10 even displaySizeId-7 even-7 collapsed last"><meta content="News"><meta content="2017-07-07 03:38:25"><h4 class="wnContent headline"><a href="/story/35830215/2017/07/06/red-wing-collectors-society-celebrates-40th-anniversary"><span class="text">Red Wing Collectors Society celebrates 40th anniversary</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35830215/2017/07/06/red-wing-collectors-society-celebrates-40th-anniversary"><span class="text">Red Wing Collectors Society celebrates 40th anniversary</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35830215/2017/07/06/red-wing-collectors-society-celebrates-40th-anniversary"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14322373_G.png"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35830215/2017/07/06/red-wing-collectors-society-celebrates-40th-anniversary"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14322373_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>You might not think pottery would be selling for thousands of dollars, but &nbsp;in Red Wing, they're doing just that with important pieces of their history with the 40th Annual Red Wing Collector's Society Member Auction.</p> </span><a class="more" href="/story/35830215/2017/07/06/red-wing-collectors-society-celebrates-40th-anniversary"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>You might not think pottery would be selling for thousands of dollars, but &nbsp;in Red Wing, they're doing just that with important pieces of their history with the 40th Annual Red Wing Collector's Society Member Auction.</p></span><a class="more" href="/story/35830215/2017/07/06/red-wing-collectors-society-celebrates-40th-anniversary"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId78');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 4 (78)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Promo Box - Col 4B (25)--><div class="wnBlock displaySize displaySizeId25 promoBox" id="DisplaySizeId25"><ul class="wnGroup contentGroup odd last"><li class="wnItem header"><h3><span class="text sectionTitle">Most Popular Stories</span><span class="text abridgedHeadline">Most Popular Stories</span><a class="wnContent more" href="/mostpopularstory"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature News story priority-1 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2017-07-07 14:31:08"><h4 class="wnContent headline"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">Three arrested at neighboring Rochester homes as part of drug investigation</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">Three arrested at neighboring Rochester homes as part of drug investigation</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325638_G.jpg" title="Samantha Bennett, Laurie Abell and Terry Heggs" alt="Samantha Bennett, Laurie Abell and Terry Heggs"></a><span class="caption left width90"><span class="text">Samantha Bennett, Laurie Abell and Terry Heggs</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325638_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Three people are facing drug charges after search warrants were carried out at neighboring Rochester homes.&nbsp; Rochester Police said the busts were part of an ongoing investigation by the Criminal Interdiction Unit.</p></span><a class="more" href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Three people are facing drug charges after search warrants were carried out at neighboring Rochester homes.&nbsp; Rochester Police said the busts were part of an ongoing investigation by the Criminal Interdiction Unit.</p></span><a class="more" href="/story/35833058/2017/07/07/three-arrested-at-neighboring-rochester-homes-as-part-of-drug-investigation"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-10 even-10"><meta content="News"><meta content="2017-07-06 17:05:42"><h4 class="wnContent headline"><a href="/story/35825858/2017/07/06/charles-city-boy-declared-brain-dead-after-atv-accident"><span class="text">Charles City boy declared brain dead after ATV accident</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35825858/2017/07/06/charles-city-boy-declared-brain-dead-after-atv-accident"><span class="text">Charles City boy declared brain dead after ATV accident</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35825858/2017/07/06/charles-city-boy-declared-brain-dead-after-atv-accident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14316926_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35825858/2017/07/06/charles-city-boy-declared-brain-dead-after-atv-accident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14316926_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A Charles City boy&nbsp;has been declared clinically brain dead after an ATV accident on Tuesday. The Charles City Community School District says&nbsp;Logan Luft would have entered the 9th grade this fall.</p> </span><a class="more" href="/story/35825858/2017/07/06/charles-city-boy-declared-brain-dead-after-atv-accident"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A Charles City boy&nbsp;has been declared clinically brain dead after an ATV accident on Tuesday. The Charles City Community School District says&nbsp;Logan Luft would have entered the 9th grade this fall.</p></span><a class="more" href="/story/35825858/2017/07/06/charles-city-boy-declared-brain-dead-after-atv-accident"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2017-07-07 14:07:30"><h4 class="wnContent headline"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">UPDATE: Two dogs reported stolen in Rochester returned to owner</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">UPDATE: Two dogs reported stolen in Rochester returned to owner</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/12719128_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/12719128_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Police are investigating after two dogs were stolen from a southeast Rochester home.&nbsp; Rochester Police said a homeowner on the 900 block of 17&frac12; Street SE let her two chihuahuas out into the fenced backyard sometime around 6:30 a.m. and 7 p.m. on Thursday.&nbsp;</p> </span><a class="more" href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Police are investigating after two dogs were stolen from a southeast Rochester home.&nbsp; Rochester Police said a homeowner on the 900 block of 17&frac12; Street SE let her two chihuahuas out into the fenced backyard sometime around 6:30 a.m. and 7 p.m. on Thursday.&nbsp;</p></span><a class="more" href="/story/35832871/2017/07/07/two-dogs-reported-stolen-from-se-rochester"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-10 even-10"><meta content="News"><meta content="2017-07-06 14:10:46"><h4 class="wnContent headline"><a href="/story/35824056/2017/07/06/police-suv-runs-over-motorcyclist-in-se-rochester-crash"><span class="text">Police: SUV runs over motorcyclist in SE Rochester crash</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35824056/2017/07/06/police-suv-runs-over-motorcyclist-in-se-rochester-crash"><span class="text">Police: SUV runs over motorcyclist in SE Rochester crash</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35824056/2017/07/06/police-suv-runs-over-motorcyclist-in-se-rochester-crash"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/7921160_G.jpg" title="Photo: MGN Online" alt="Photo: MGN Online"></a><span class="caption left width90"><span class="text">Photo: MGN Online</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35824056/2017/07/06/police-suv-runs-over-motorcyclist-in-se-rochester-crash"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/7921160_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>An Elgin woman underwent surgery for injuries suffered in a motorcycle crash Wednesday evening.&nbsp; Rochester Police said a&nbsp;Kawasaki Racer motorcycle was westbound on 4th Street when a GMC Envoy pulled out from the Shell Station.&nbsp;</p> </span><a class="more" href="/story/35824056/2017/07/06/police-suv-runs-over-motorcyclist-in-se-rochester-crash"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>An Elgin woman underwent surgery for injuries suffered in a motorcycle crash Wednesday evening.&nbsp; Rochester Police said a&nbsp;Kawasaki Racer motorcycle was westbound on 4th Street when a GMC Envoy pulled out from the Shell Station.&nbsp;</p></span><a class="more" href="/story/35824056/2017/07/06/police-suv-runs-over-motorcyclist-in-se-rochester-crash"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-5 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2017-07-07 14:35:16"><h4 class="wnContent headline"><a href="/story/35833078/2017/07/07/byron-grill-fire-causes-thousands-of-dollars-in-damage"><span class="text">Byron grill fire causes thousands of dollars in damage</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35833078/2017/07/07/byron-grill-fire-causes-thousands-of-dollars-in-damage"><span class="text">Byron grill fire causes thousands of dollars in damage</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35833078/2017/07/07/byron-grill-fire-causes-thousands-of-dollars-in-damage"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325651_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35833078/2017/07/07/byron-grill-fire-causes-thousands-of-dollars-in-damage"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325651_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The side of a house caught&nbsp;on fire while a&nbsp;man was grilling Thursday, causing thousands of dollars in damage.</p> </span><a class="more" href="/story/35833078/2017/07/07/byron-grill-fire-causes-thousands-of-dollars-in-damage"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The side of a house caught&nbsp;on fire while a&nbsp;man was grilling Thursday, causing thousands of dollars in damage.</p></span><a class="more" href="/story/35833078/2017/07/07/byron-grill-fire-causes-thousands-of-dollars-in-damage"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-6 even displaySizeId-10 even-10"><meta content="News"><meta content="2017-07-05 17:07:23"><h4 class="wnContent headline"><a href="/story/35816103/2017/07/05/teen-killed-in-millville-atv-accident"><span class="text">Teen killed in Millville ATV accident</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35816103/2017/07/05/teen-killed-in-millville-atv-accident"><span class="text">Teen killed in Millville ATV accident</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35816103/2017/07/05/teen-killed-in-millville-atv-accident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14306951_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35816103/2017/07/05/teen-killed-in-millville-atv-accident"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14306951_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A teenage boy was killed while competing at Spring Creek Motocross Park over the weekend. A family member said on a GoFundMe Page created in his memory, Kyler Lenz, 14, died from head trauma after he was thrown from his ATV.</p> </span><a class="more" href="/story/35816103/2017/07/05/teen-killed-in-millville-atv-accident"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A teenage boy was killed while competing at Spring Creek Motocross Park over the weekend. A family member said on a GoFundMe Page created in his memory, Kyler Lenz, 14, died from head trauma after he was thrown from his ATV.</p></span><a class="more" href="/story/35816103/2017/07/05/teen-killed-in-millville-atv-accident"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-7 odd displaySizeId-10 odd-10"><meta content="News"><meta content="2017-07-05 14:26:46"><h4 class="wnContent headline"><a href="/story/35814903/2017/07/05/update-body-found-in-austins-mill-pond-identified"><span class="text">UPDATE: Body found in Austin's Mill Pond identified</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35814903/2017/07/05/update-body-found-in-austins-mill-pond-identified"><span class="text">UPDATE: Body found in Austin's Mill Pond identified</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35814903/2017/07/05/update-body-found-in-austins-mill-pond-identified"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14305589_G.jpg" title="Crews work to recover a body from Mill Pond behind the Austin Public Library Wednesday morning" alt="Crews work to recover a body from Mill Pond behind the Austin Public Library Wednesday morning"></a><span class="caption left width90"><span class="text">Crews work to recover a body from Mill Pond behind the Austin Public Library Wednesday morning</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35814903/2017/07/05/update-body-found-in-austins-mill-pond-identified"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14305589_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Firefighters in Austin are working to recover a body from Mill Pond Wednesday morning.&nbsp; Austin Police Chief Brian Krueger said officers received a call about the body floating in the lagoon behind the Austin Library at 8:02 a.m.&nbsp;</p></span><a class="more" href="/story/35814903/2017/07/05/update-body-found-in-austins-mill-pond-identified"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Firefighters in Austin are working to recover a body from Mill Pond Wednesday morning.&nbsp; Austin Police Chief Brian Krueger said officers received a call about the body floating in the lagoon behind the Austin Library at 8:02 a.m.&nbsp;</p></span><a class="more" href="/story/35814903/2017/07/05/update-body-found-in-austins-mill-pond-identified"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-8 even displaySizeId-10 even-10 last"><meta content="News"><meta content="2017-07-07 13:57:46"><h4 class="wnContent headline"><a href="/story/35832778/2017/07/07/down-by-the-riverside-concert-series-returns-for-2017-season"><span class="text">Down By the Riverside concert series returns for 2017 season</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35832778/2017/07/07/down-by-the-riverside-concert-series-returns-for-2017-season"><span class="text">Down By the Riverside concert series returns for 2017 season</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35832778/2017/07/07/down-by-the-riverside-concert-series-returns-for-2017-season"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325428_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35832778/2017/07/07/down-by-the-riverside-concert-series-returns-for-2017-season"><img border="0" width="90" data-path="http://KTTC.images.worldnow.com/images/14325428_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>An annual summer concert series that brings huge crowds to the banks of the Zumbro will return for the 26th year this weekend. Sunday marks the beginning of the 2017 Down By the Riverside series.&nbsp;</p> </span><a class="more" href="/story/35832778/2017/07/07/down-by-the-riverside-concert-series-returns-for-2017-season"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>An annual summer concert series that brings huge crowds to the banks of the Zumbro will return for the 26th year this weekend. Sunday marks the beginning of the 2017 Down By the Riverside series.&nbsp;</p></span><a class="more" href="/story/35832778/2017/07/07/down-by-the-riverside-concert-series-returns-for-2017-season"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId25');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Promo Box - Col 4B (25)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://KTTC.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText"><div class="footer-top clearfix">
	<div class="footer-search clearfix">
		<div class="footer-search-text">Can't Find Something?</div>
		<div class="footer-search-box">
			<form action="/search" method="get" onsubmit="return wnValidateSearchTerm(this, 0)">
	        	<input type="hidden" name="vendor" value="ez">
	        	<input class="footer-textbox" type="text" name="qu" value="" placeholder="Search">
	       		<input class="footer-submit" type="submit" value="Go">
	    	</form>
    	</div>
	</div>
	<div class="station-logo"></div>
	<div class="station-info">
        <p class='address'><strong>KTTC</strong><br />
         	6301 Bandel Road NW, Rochester, MN 55901<br />
        	Switchboard: 507-288-4444<br />
		News tips: 507-280-5125 or <a href="mailto:news@kttc.com">news@kttc.com</a><br />
         	         	<div>
	         	<a class="info" href="http://www.kttc.com/category/134180/kttc-jobs">Careers</a>
	         	<a class="info" href="http://www.kttc.com/link/781956/advertise-with-kttc">Advertise with us</a>
         		<a class="info" href="https://xprspay.ipayxepay.net/xprspay/qmi/index.jsp">Advertiser Services </a>
		</div>
         	<div>
	         	<a class="info" target="_blank" href="https://publicfiles.fcc.gov/tv-profile/kttc">FCC Public File</a>
	         	<a class="info" target="_blank" href="http://www.kttc.com/link/739878/eeo-report">EEO Report</a>
	         	<a class="info" href="http://www.kttc.com/story/35022866/2017/03/29/kttc-closed-caption-contact">Closed Captioning Contact</a>
         	</div> 
         	      	        	
        </p>
	</div>
</div>
<div class="footer-middle clearfix"></div>
<div class="footer-bottom clearfix">
	<div class="inner">
		<div class="copyrightText">
			<a id="wnLogo" href="http://www.worldnow.com"><img src="http://ftpcontent.worldnow.com/wncorp/logos/worldnow_white.png" id="wn"></a>
	    	<div class="text">
				All content &copy; Copyright 2000 - 2017 KTTC. All Rights Reserved. For more information on this site, please read our <a href="/story/15534331/privacy-policy">Privacy Policy</a>,, <a href="/story/18991/terms-of-service">Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.
	    	</div>
	    	<div class="clear"></div>       
		</div>
	</div>
</div></div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>